Read the docs
TI-2024-35725 Aliases CVE-2024-53262GHSA-mh2x-fcqh-fmqv

Unescaped error message included on error page in SvelteKit

Priority LOW 11CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
High
Attack requirements
Present
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. The static error.html template for errors contains placeholders that are replaced without escaping the content first. error.html is the page that is rendered when everything else fails. It can contain the following placeholders: %sveltekit.status% — the HTTP status, and %sveltekit.error.message% — the error message. This leads to possible injection if an app explicitly creates an error with a message that contains user controlled content. Only applications where user provided input is used in the `Error` message will be vulnerable, so the vast majority of applications will not be vulnerable This issue has been addressed in version 2.8.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00513 43rd percentileScored 2026-11-07
Fix Fixed kit (sveltejs): 2.8.3@sveltejs/kit (npm): 2.8.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
sveltejskitbefore 2.8.32.8.3Patch availableCNA
—@sveltejs/kit (npm)before 2.8.32.8.3Patch availableGHSA-mh2x-fcqh-fmqv
  • kit Vendorsveltejs Affected before 2.8.3 Fixed in 2.8.3 Patch available CNA
  • @sveltejs/kit (npm) Vendor— Affected before 2.8.3 Fixed in 2.8.3 Patch available GHSA-mh2x-fcqh-fmqv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:svelte:sveltekit:*:*:*:*:*:node.js:*:*before 2.8.3Vulnerablesveltejs
  • cpe:2.3:a:svelte:sveltekit:*:*:*:*:*:node.js:*:* Versions before 2.8.3 Vulnerable ·sveltejs

Remediation

  • Fix · CNA kit (sveltejs) Fixed in 2.8.3
  • Fix · GHSA-mh2x-fcqh-fmqv @sveltejs/kit (npm) Fixed in 2.8.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-53262
  2. 2026-10-03 Alias added: GHSA-mh2x-fcqh-fmqv

References

  • TI-2023-13469 SvelteKit framework has Insufficient CSRF protection for CORS requests CVSS 3.1HIGH 8.8
  • TI-2023-13464 SvelteKit has Insufficient Cross-Site Request Forgery Protection CVSS 3.1HIGH 8.8
  • TI-2026-56726 SvelteKit before 2.52.2 CPU Exhaustion via Remote Form Deserialization CVSS 4.0HIGH 8.7
  • TI-2026-56725 SvelteKit before 2.52.2 Memory Exhaustion via Remote Form Deserialization CVSS 4.0HIGH 8.7
  • TI-2026-56724 SvelteKit 2.49.0 before 2.53.3 Denial of Service via form CVSS 4.0HIGH 8.7
  • TI-2026-56721 SvelteKit before 2.69.1 Denial of Service via Remote Form CVSS 4.0MEDIUM 6.9
See all 9 →

Sources