Read the docs
TI-2024-35878 Aliases CVE-2024-53678GHSA-fwrx-wppx-25wm

Apache VCL: SQL injection vulnerability in New Block Allocation form

Priority LOW 26CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
Low · None · None
Fix status
No fix listed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache VCL. Users can modify form data submitted when requesting a new Block Allocation such that a SELECT SQL statement is modified. The data returned by the SELECT statement is not viewable by the attacker. This issue affects all versions of Apache VCL from 2.2 through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0062 49th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache VCL2.2 – 2.5.1—No fix listedCNA
  • Apache VCL VendorApache Affected 2.2 – 2.5.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:vcl:*:*:*:*:*:*:*:*2.2 to before 2.5.2VulnerableApache
  • cpe:2.3:a:apache:vcl:*:*:*:*:*:*:*:* Versions 2.2 to before 2.5.2 Vulnerable ·Apache

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-53678
  2. 2026-10-03 Alias added: GHSA-fwrx-wppx-25wm

References

  • TI-2013-00201 The Privileges portion of the web GUI and the XMLRPC API in Apache VCL 2.3.x before… CVSS 3.0HIGH 8.8
  • TI-2024-35879 Apache VCL: XSS vulnerability in User Lookup impacting user privileges CVSS 4.0HIGH 8.4

Sources