Read the docs
TI-2024-35879 Aliases CVE-2024-53679GHSA-92pj-xr28-j7xr

Apache VCL: XSS vulnerability in User Lookup impacting user privileges

Priority LOW 37CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache VCL in the User Lookup form. A user with sufficient rights to be able to view this part of the site can craft a URL or be tricked in to clicking a URL that will give a specified user elevated rights. This issue affects all versions of Apache VCL through 2.5.1. Users are recommended to upgrade to version 2.5.2, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00536 45th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache VCL2.1 – 2.5.1—No fix listedCNA
  • Apache VCL VendorApache Affected 2.1 – 2.5.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:vcl:*:*:*:*:*:*:*:*2.1 to before 2.5.2VulnerableApache
  • cpe:2.3:a:apache:vcl:*:*:*:*:*:*:*:* Versions 2.1 to before 2.5.2 Vulnerable ·Apache

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-53679
  2. 2026-10-03 Alias added: GHSA-92pj-xr28-j7xr

References

  • TI-2013-00201 The Privileges portion of the web GUI and the XMLRPC API in Apache VCL 2.3.x before… CVSS 3.0HIGH 8.8
  • TI-2024-35878 Apache VCL: SQL injection vulnerability in New Block Allocation form CVSS 4.0MEDIUM 5.1

Sources