Read the docs
TI-2024-36940 Aliases CVE-2024-55661GHSA-8vwh-pr89-4mw2

Laravel Pulse Allows Remote Code Execution via Unprotected Query Method

Priority HIGH 73CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Laravel Pulse is a real-time application performance monitoring tool and dashboard for Laravel applications. A vulnerability has been discovered in Laravel Pulse prior to version 1.3.1 that could allow remote code execution through the public `remember()` method in the `Laravel\Pulse\Livewire\Concerns\RemembersQueries` trait. This method is accessible via Livewire components and can be exploited to call arbitrary callables within the application. An authenticated user with access to Laravel Pulse dashboard can execute arbitrary code by calling any function or static method in which the callable is a function or static method and the callable has no parameters or no strict parameter types. The vulnerable to component is `remember(callable $query, string $key = '')` method in `Laravel\Pulse\Livewire\Concerns\RemembersQueries`, and the vulnerability affects all Pulse card components that use this trait. Version 1.3.1 contains a patch.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.30649 98th percentileScored 2026-11-07
Fix Fixed pulse (laravel): 1.3.1laravel/pulse (Packagist): 1.3.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Laravelpulsebefore 1.3.11.3.1Patch availableCNA
—laravel/pulse (Packagist)before 1.3.11.3.1Patch availableGHSA-8vwh-pr89-4mw2
  • pulse VendorLaravel Affected before 1.3.1 Fixed in 1.3.1 Patch available CNA
  • laravel/pulse (Packagist) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-8vwh-pr89-4mw2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:laravel:pulse:*:*:*:*:*:*:*:*before 1.3.1VulnerableLaravel
  • cpe:2.3:a:laravel:pulse:*:*:*:*:*:*:*:* Versions before 1.3.1 Vulnerable ·Laravel

Remediation

  • Fix · CNA pulse (laravel) Fixed in 1.3.1
  • Fix · GHSA-8vwh-pr89-4mw2 laravel/pulse (Packagist) Fixed in 1.3.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-55661
  2. 2026-10-03 Alias added: GHSA-8vwh-pr89-4mw2

References

Sources