RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 4.0.0-RC1 to before 4.13.2; 5.0.0-RC1 to before 5.5.2; 3.0.0 to before 3.9.14 | 4.13.2, 5.5.2, 3.9.14 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.5.2 | 5.5.2 | Patch available | GHSA-2p6p-9rc9-62j9 |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.13.2 | 4.13.2 | Patch available | GHSA-2p6p-9rc9-62j9 |
| — | craftcms/cms (Packagist) | 3.0.0 to before 3.9.14 | 3.9.14 | Patch available | GHSA-2p6p-9rc9-62j9 |
- cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.13.2; 5.0.0-RC1 to before 5.5.2; 3.0.0 to before 3.9.14 Fixed in 4.13.2, 5.5.2, 3.9.14 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.5.2 Fixed in 5.5.2 Patch available GHSA-2p6p-9rc9-62j9
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.13.2 Fixed in 4.13.2 Patch available GHSA-2p6p-9rc9-62j9
- craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 3.9.14 Fixed in 3.9.14 Patch available GHSA-2p6p-9rc9-62j9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | 3.0.0 to before 3.9.14; 4.0.0 to before 4.13.2; 5.0.0 to before 5.5.2 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.9.14; 4.0.0 to before 4.13.2; 5.0.0 to before 5.5.2 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 4.13.2, 5.5.2, 3.9.14
- Fix · GHSA-2p6p-9rc9-62j9 craftcms/cms (Packagist) Fixed in 5.5.2 Advisory →
- Fix · GHSA-2p6p-9rc9-62j9 craftcms/cms (Packagist) Fixed in 4.13.2 Advisory →
- Fix · GHSA-2p6p-9rc9-62j9 craftcms/cms (Packagist) Fixed in 3.9.14 Advisory →
Timeline
- 2025-06-02 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2024-56145
- 2026-10-03 Alias added: GHSA-2p6p-9rc9-62j9
References
Advisory 2
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
- TI-2020-07842 The SEOmatic component before 3.3.0 for Craft CMS allows Server-Side Template Injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-56145 · CVE Program
- CVE-2024-56145 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-2p6p-9rc9-62j9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences