Craft CMS Allows Remote Code Execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 3.0.0-RC1 to before 3.9.15; 4.0.0-RC1 to before 4.14.15; 5.0.0-RC1 to before 5.6.17 | 3.9.15, 4.14.15, 5.6.17 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 3.0.0-RC1 to before 3.9.15 | 3.9.15 | Patch available | GHSA-f3gw-9ww9-jmc3 |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.14.15 | 4.14.15 | Patch available | GHSA-f3gw-9ww9-jmc3 |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.6.17 | 5.6.17 | Patch available | GHSA-f3gw-9ww9-jmc3 |
- cms VendorCraft CMS Affected 3.0.0-RC1 to before 3.9.15; 4.0.0-RC1 to before 4.14.15; 5.0.0-RC1 to before 5.6.17 Fixed in 3.9.15, 4.14.15, 5.6.17 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 3.0.0-RC1 to before 3.9.15 Fixed in 3.9.15 Patch available GHSA-f3gw-9ww9-jmc3
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.14.15 Fixed in 4.14.15 Patch available GHSA-f3gw-9ww9-jmc3
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.6.17 Fixed in 5.6.17 Patch available GHSA-f3gw-9ww9-jmc3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | 3.0.0 to before 3.9.15; 4.0.0 to before 4.14.15; 5.0.0 to before 5.6.17 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.9.15; 4.0.0 to before 4.14.15; 5.0.0 to before 5.6.17 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 3.9.15, 4.14.15, 5.6.17
- Fix · GHSA-f3gw-9ww9-jmc3 craftcms/cms (Packagist) Fixed in 3.9.15 Advisory →
- Fix · GHSA-f3gw-9ww9-jmc3 craftcms/cms (Packagist) Fixed in 4.14.15 Advisory →
- Fix · GHSA-f3gw-9ww9-jmc3 craftcms/cms (Packagist) Fixed in 5.6.17 Advisory →
Timeline
- 2026-03-20 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2025-32432
- 2026-10-03 Alias added: GHSA-f3gw-9ww9-jmc3
References
Exploit 1
Advisory 2
Other 8
- https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical
- https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical
- https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical
- https://github.com/craftcms/cms/security/advisories/GHSA-4w8r-3xrw-v25g
- https://craftcms.com/knowledge-base/craft-cms-cve-2025-32432
- https://github.com/craftcms/cms
- https://sensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcms
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32432
More Craft Cms vulnerabilities
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
- TI-2020-07842 The SEOmatic component before 3.3.0 for Craft CMS allows Server-Side Template Injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-32432 · CVE Program
- CVE-2025-32432 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-f3gw-9ww9-jmc3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences