phpMyFAQ Vulnerable to Stored HTML Injection at FAQ
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, damage to the user experience, and potential abuse in phishing or defacement attacks. Version 4.0.2 contains a patch for the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| thorsten | phpMyFAQ | 3.2.10 to before 4.0.2 | 4.0.2 | Patch available | CNA |
| — | phpmyfaq/phpmyfaq (Packagist) | 3.2.10 – 4.0.1 | — | No fix listed | GHSA-ww33-jppq-qfrp |
| — | thorsten/phpmyfaq (Packagist) | 3.2.10 – 4.0.1 | — | No fix listed | GHSA-ww33-jppq-qfrp |
- phpMyFAQ Vendorthorsten Affected 3.2.10 to before 4.0.2 Fixed in 4.0.2 Patch available CNA
- phpmyfaq/phpmyfaq (Packagist) Vendor— Affected 3.2.10 – 4.0.1 Fixed in — No fix listed GHSA-ww33-jppq-qfrp
- thorsten/phpmyfaq (Packagist) Vendor— Affected 3.2.10 – 4.0.1 Fixed in — No fix listed GHSA-ww33-jppq-qfrp
Remediation
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.0.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56199
- 2026-10-03 Alias added: GHSA-ww33-jppq-qfrp
References
More thorsten Phpmyfaq vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
- TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
- TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-56199 · CVE Program
- CVE-2024-56199 · NVD
- FIRST EPSS
- GHSA-ww33-jppq-qfrp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences