The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.
Priority MEDIUM 42CWE-426Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-426.
Summary
The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00236 14th percentileScored 2026-11-07
Fix Fixed ppp (Samba): 2.5.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ppp (Samba) Fixed in 2.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-58250
- 2026-10-03 Alias added: GHSA-v77v-qh6r-74qh
References
More Samba vulnerabilities
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2017-05139 Code injection in samba KEVCVSS 3.1CRITICAL 9.8
- TI-2024-11208 Rsync: heap buffer overflow in rsync due to improper checksum length handling CVSS 3.1CRITICAL 9.8
- TI-2015-00210 The Netlogon server implementation in smbd in Samba 3.5.x and 3.6.x before 3.6.25, 4.0.x… CVSS 2.0HIGH 10.0
- TI-2003-00081 Buffer overflow in the SMB/CIFS packet fragment re-assembly code for SMB daemon (smbd) in… CVSS 2.0HIGH 10.0
- TI-2003-00185 Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before… CVSS 2.0HIGH 10.0
Sources
- CVE-2024-58250 · CVE Program
- CVE-2024-58250 · NVD
- FIRST EPSS
- GHSA-v77v-qh6r-74qh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences