Read the docs
TI-2025-00507 Aliases CVE-2025-0605GHSA-v9g5-36x8-7xmx

Weak Authentication in GitLab

Priority LOW 21CWE-1390Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.

Summary

An issue has been discovered in GitLab CE/EE affecting all versions from 16.8 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Group access controls could allow certain users to bypass two-factor authentication requirements.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00324 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed GitLab (GitLab): 17.10.7, 17.11.3, 18.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab16.8 to before 17.10.7; 17.11 to before 17.11.3; 18.0 to before 18.0.117.10.7, 17.11.3, 18.0.1Patch availableCNA
  • GitLab VendorGitLab Affected 16.8 to before 17.10.7; 17.11 to before 17.11.3; 18.0 to before 18.0.1 Fixed in 17.10.7, 17.11.3, 18.0.1 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*16.8.0 to before 17.10.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*16.8.0 to before 17.10.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*17.11.0 to before 17.11.3VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*17.11.0 to before 17.11.3VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:community:*:*:*18.0.0VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:enterprise:*:*:*18.0.0VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.8.0 to before 17.10.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.8.0 to before 17.10.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.11.0 to before 17.11.3 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.11.0 to before 17.11.3 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:community:*:*:* Versions 18.0.0 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:18.0.0:*:*:*:enterprise:*:*:* Versions 18.0.0 Vulnerable ·GitLab

Remediation

  • Fix · CNA GitLab (GitLab) Fixed in 17.10.7, 17.11.3, 18.0.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    GitLab 17.10.7, 17.11.3, 18.0.1

    7 records Highest priority Priority LOW 7 LOW

    Other records, highest priority first

    • TI-2025-04463 Insufficient Granularity of Access Control in GitLabPriority LOW 33
    • TI-2025-00836 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 33
    • TI-2024-11217 Improper Validation of Consistency within Input in GitLabPriority LOW 31

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-0605
  2. 2026-10-03 Alias added: GHSA-v9g5-36x8-7xmx

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources