Favorites < 2.3.5 - Admin+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Favorites WordPress plugin before 2.3.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00267 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Favorites (Unknown): 2.3.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Favorites | before 2.3.5 | 2.3.5 | Patch available | CNA |
- Favorites VendorUnknown Affected before 2.3.5 Fixed in 2.3.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:favoriteposts:favorites:*:*:*:*:*:wordpress:*:* | before 2.3.5 | Vulnerable | Favoriteposts |
- cpe:2.3:a:favoriteposts:favorites:*:*:*:*:*:wordpress:*:* Versions before 2.3.5 Vulnerable ·Favoriteposts
Remediation
- Fix · CNA Favorites (Unknown) Fixed in 2.3.5
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1452
- 2026-10-03 Alias added: GHSA-rgxv-4464-wf8w
References
More Favoriteposts Favorites vulnerabilities
- TI-2023-02161 Favorites <= 2.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2025-1452 · CVE Program
- CVE-2025-1452 · NVD
- FIRST EPSS
- GHSA-rgxv-4464-wf8w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences