MapPress Maps for WordPress < 2.94.9 - Contributor+ Stored XSS
Priority HIGH 65CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The MapPress Maps for WordPress plugin before 2.94.9 does not sanitise and escape some parameters when outputing them in the page, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00472 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MapPress Maps for WordPress (Unknown): 2.94.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MapPress Maps for WordPress | before 2.94.9 | 2.94.9 | Patch available | CNA |
- MapPress Maps for WordPress VendorUnknown Affected before 2.94.9 Fixed in 2.94.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mappresspro:mappress:*:*:*:*:free:wordpress:*:* | before 2.94.9 | Vulnerable | chrisvrichardson |
- cpe:2.3:a:mappresspro:mappress:*:*:*:*:free:wordpress:*:* Versions before 2.94.9 Vulnerable ·chrisvrichardson
Remediation
- Fix · CNA MapPress Maps for WordPress (Unknown) Fixed in 2.94.9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2055
- 2026-10-03 Alias added: GHSA-wh3v-xmpm-9x73
References
More chrisvrichardson Mappress vulnerabilities
- TI-2023-05979 MapPress Maps for WordPress <= 2.88.13 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2025-01894 MapPress Maps for WordPress < 2.94.10 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-07996 MapPress Maps for WordPress < 2.93 - Admin+ Stored XSS via Map Settings CVSS 3.1MEDIUM 4.8
- TI-2023-11256 WordPress MapPress Maps for WordPress Plugin <= 2.85.4 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2020-09728 The mappress-google-maps-for-wordpress plugin before 2.53.9 for WordPress does not… CVSS 3.1HIGH 8.8
- TI-2020-10079 The mappress-google-maps-for-wordpress plugin before 2.54.6 for WordPress does not… CVSS 3.1HIGH 8.8
Sources
- CVE-2025-2055 · CVE Program
- CVE-2025-2055 · NVD
- FIRST EPSS
- GHSA-wh3v-xmpm-9x73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences