MapPress Maps for WordPress < 2.94.10 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The MapPress Maps for WordPress plugin before 2.94.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00396 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MapPress Maps for WordPress (Unknown): 2.94.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MapPress Maps for WordPress | 2.94.9 to before 2.94.10 | 2.94.10 | Patch available | CNA |
- MapPress Maps for WordPress VendorUnknown Affected 2.94.9 to before 2.94.10 Fixed in 2.94.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mappresspro:mappress:*:*:*:*:free:wordpress:*:* | before 2.94.10 | Vulnerable | chrisvrichardson |
- cpe:2.3:a:mappresspro:mappress:*:*:*:*:free:wordpress:*:* Versions before 2.94.10 Vulnerable ·chrisvrichardson
Remediation
- Fix · CNA MapPress Maps for WordPress (Unknown) Fixed in 2.94.10
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2162
- 2026-10-03 Alias added: GHSA-ffc2-m4f8-5m2g
References
More chrisvrichardson Mappress vulnerabilities
- TI-2025-01793 MapPress Maps for WordPress < 2.94.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-05979 MapPress Maps for WordPress <= 2.88.13 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-07996 MapPress Maps for WordPress < 2.93 - Admin+ Stored XSS via Map Settings CVSS 3.1MEDIUM 4.8
- TI-2023-11256 WordPress MapPress Maps for WordPress Plugin <= 2.85.4 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2020-09728 The mappress-google-maps-for-wordpress plugin before 2.53.9 for WordPress does not… CVSS 3.1HIGH 8.8
- TI-2020-10079 The mappress-google-maps-for-wordpress plugin before 2.54.6 for WordPress does not… CVSS 3.1HIGH 8.8
Sources
- CVE-2025-2162 · CVE Program
- CVE-2025-2162 · NVD
- FIRST EPSS
- GHSA-ffc2-m4f8-5m2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences