System Admin Cannot Access Environment settings in System Console While System Manager Can
Priority LOW 14CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 10.5.x <= 10.5.3, 9.11.x <= 9.11.11 fail to check `RestrictSystemAdmin` setting if user doesn't have access to `ExperimentalSettings` which allows a System Manager to access `ExperimentSettings` when `RestrictSystemAdmin` is true via System Console.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.7.0, 10.5.3, 9.11.12github.com/mattermost/mattermost/server/v8 (Go): 10.5.3, 9.11.12, 8.0.0-20250411064244-844447fbd57c
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.5.0 – 10.5.2; 9.11.0 – 9.11.11 | 10.7.0, 10.5.3, 9.11.12 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.5.0 to before 10.5.3 | 10.5.3 | Patch available | GHSA-fpff-wj6m-grvr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.11.0 to before 9.11.12 | 9.11.12 | Patch available | GHSA-fpff-wj6m-grvr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20250411064244-844447fbd57c | 8.0.0-20250411064244-844447fbd57c | Patch available | GHSA-fpff-wj6m-grvr |
- Mattermost VendorMattermost Affected 10.5.0 – 10.5.2; 9.11.0 – 9.11.11 Fixed in 10.7.0, 10.5.3, 9.11.12 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.5.0 to before 10.5.3 Fixed in 10.5.3 Patch available GHSA-fpff-wj6m-grvr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.11.0 to before 9.11.12 Fixed in 9.11.12 Patch available GHSA-fpff-wj6m-grvr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20250411064244-844447fbd57c Fixed in 8.0.0-20250411064244-844447fbd57c Patch available GHSA-fpff-wj6m-grvr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.12; 10.5.0 to before 10.5.4 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.12; 10.5.0 to before 10.5.4 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.7.0, 10.5.3, 9.11.12
- Fix · GHSA-fpff-wj6m-grvr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.5.3 Advisory →
- Fix · GHSA-fpff-wj6m-grvr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.12 Advisory →
- Fix · GHSA-fpff-wj6m-grvr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20250411064244-844447fbd57c Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2570
- 2026-10-03 Alias added: GHSA-fpff-wj6m-grvr
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-2570 · CVE Program
- CVE-2025-2570 · NVD
- FIRST EPSS
- GHSA-fpff-wj6m-grvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences