Google OAuth Authentication Bypass for Converted Bot Accounts
Priority LOW 19CWE-303Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to clear Google OAuth credentials when converting user accounts to bot accounts, allowing attackers to gain unauthorized access to bot accounts via the Google OAuth signup flow.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00214 11th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.8.0, 10.7.1, 10.6.3 +2github.com/mattermost/mattermost/server/v8 (Go): 10.7.1, 10.5.4, 9.11.13 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.7.0; 10.6.0 – 10.6.2; 10.5.0 – 10.5.3; 9.11.0 – 9.11.12 | 10.8.0, 10.7.1, 10.6.3, 10.5.4, 9.11.13 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.7.0-rc1 to before 10.7.1 | 10.7.1 | Patch available | GHSA-8cgx-9ccj-3gwr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.0.0-rc1 to before 10.5.4 | 10.5.4 | Patch available | GHSA-8cgx-9ccj-3gwr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.0.0-rc1 to before 9.11.13 | 9.11.13 | Patch available | GHSA-8cgx-9ccj-3gwr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20250414095146-04676582cdd2 | 8.0.0-20250414095146-04676582cdd2 | Patch available | GHSA-8cgx-9ccj-3gwr |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.6.0-rc1 to before 10.6.3 | 10.6.3 | Patch available | GHSA-8cgx-9ccj-3gwr |
- Mattermost VendorMattermost Affected 10.7.0; 10.6.0 – 10.6.2; 10.5.0 – 10.5.3; 9.11.0 – 9.11.12 Fixed in 10.8.0, 10.7.1, 10.6.3, 10.5.4, 9.11.13 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.7.0-rc1 to before 10.7.1 Fixed in 10.7.1 Patch available GHSA-8cgx-9ccj-3gwr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.0.0-rc1 to before 10.5.4 Fixed in 10.5.4 Patch available GHSA-8cgx-9ccj-3gwr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.0.0-rc1 to before 9.11.13 Fixed in 9.11.13 Patch available GHSA-8cgx-9ccj-3gwr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20250414095146-04676582cdd2 Fixed in 8.0.0-20250414095146-04676582cdd2 Patch available GHSA-8cgx-9ccj-3gwr
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.6.0-rc1 to before 10.6.3 Fixed in 10.6.3 Patch available GHSA-8cgx-9ccj-3gwr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.13; 10.5.0 to before 10.5.4; 10.6.0 to before 10.6.3; 10.7.0 to before 10.7.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.13; 10.5.0 to before 10.5.4; 10.6.0 to before 10.6.3; 10.7.0 to before 10.7.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.8.0, 10.7.1, 10.6.3, 10.5.4, 9.11.13
- Fix · GHSA-8cgx-9ccj-3gwr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.7.1 Advisory →
- Fix · GHSA-8cgx-9ccj-3gwr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.5.4 Advisory →
- Fix · GHSA-8cgx-9ccj-3gwr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.13 Advisory →
- Fix · GHSA-8cgx-9ccj-3gwr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20250414095146-04676582cdd2 Advisory →
- Fix · GHSA-8cgx-9ccj-3gwr github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2571
- 2026-10-03 Alias added: GHSA-8cgx-9ccj-3gwr
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-2571 · CVE Program
- CVE-2025-2571 · NVD
- FIRST EPSS
- GHSA-8cgx-9ccj-3gwr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences