WP Maps < 4.7.2 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Maps WordPress plugin before 4.7.2 does not sanitise and escape some of its Map settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Maps | before 4.7.2 | 4.7.2 | Patch available | CNA |
- WP Maps VendorUnknown Affected before 4.7.2 Fixed in 4.7.2 Patch available CNA
Remediation
- Fix · CNA WP Maps (Unknown) Fixed in 4.7.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WP Maps 4.7.2
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2025-03078 WP Maps < 4.7.2 - Admin+ Stored XSSPriority MEDIUM 55
- TI-2025-03077 WP Maps < 4.7.2 - Admin+ Stored XSSPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3502
- 2026-10-03 Alias added: GHSA-f6f3-grvj-5rhr
References
More Weplugins Wp Maps vulnerabilities
- TI-2025-03078 WP Maps < 4.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2025-03077 WP Maps < 4.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-12741 WordPress WP Google Map Plugin Plugin <= 4.4.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-09190 WordPress WP Google Map plugin <= 4.2.3 - Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2015-07686 The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit category feature. CVSS 3.1HIGH 8.8
- TI-2015-07685 The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit map feature. CVSS 3.1HIGH 8.8
Sources
- CVE-2025-3502 · CVE Program
- CVE-2025-3502 · NVD
- FIRST EPSS
- GHSA-f6f3-grvj-5rhr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences