Read the docs
TI-2025-03164 Aliases CVE-2025-3597GHSA-hhrx-pjm2-54m9

Firelight Lightbox < 2.3.15 - Contributor+ Stored XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Firelight Lightbox WordPress plugin before 2.3.15 does not prevent users with post writing capabilities from executing arbitrary Javascript when the jQuery Metadata library is enabled. While this feature is meant to only be available to Pro version users, it can be activated in the free version too, making it theoretically exploitable there as well.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00319 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Firelight Lightbox (Unknown): 2.3.15

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownFirelight Lightboxbefore 2.3.152.3.15Patch availableCNA
  • Firelight Lightbox VendorUnknown Affected before 2.3.15 Fixed in 2.3.15 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:firelightwp:firelight_lightbox:*:*:*:*:*:wordpress:*:*before 2.3.15Vulnerablefirelightwp
  • cpe:2.3:a:firelightwp:firelight_lightbox:*:*:*:*:*:wordpress:*:* Versions before 2.3.15 Vulnerable ·firelightwp

Remediation

  • Fix · CNA Firelight Lightbox (Unknown) Fixed in 2.3.15

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3597
  2. 2026-10-03 Alias added: GHSA-hhrx-pjm2-54m9

References

  • TI-2025-04514 Firelight Lightbox < 2.3.16 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-33892 WordPress Firelight Lightbox plugin <= 2.3.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9

Sources