Firelight Lightbox < 2.3.16 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Firelight Lightbox WordPress plugin before 2.3.16 does not sanitise and escape title attributes before outputting them in the page, which could allow users with a role as low as contributors to perform stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00234 14th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Firelight Lightbox (Unknown): 2.3.16
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Firelight Lightbox | before 2.3.16 | 2.3.16 | Patch available | CNA |
- Firelight Lightbox VendorUnknown Affected before 2.3.16 Fixed in 2.3.16 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:firelightwp:firelight_lightbox:*:*:*:*:*:wordpress:*:* | before 2.3.16 | Vulnerable | firelightwp |
- cpe:2.3:a:firelightwp:firelight_lightbox:*:*:*:*:*:wordpress:*:* Versions before 2.3.16 Vulnerable ·firelightwp
Remediation
- Fix · CNA Firelight Lightbox (Unknown) Fixed in 2.3.16
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5035
- 2026-10-03 Alias added: GHSA-3244-863h-59jf
References
More firelightwp Firelight Lightbox vulnerabilities
- TI-2025-03164 Firelight Lightbox < 2.3.15 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-33892 WordPress Firelight Lightbox plugin <= 2.3.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2025-5035 · CVE Program
- CVE-2025-5035 · NVD
- FIRST EPSS
- GHSA-3244-863h-59jf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences