PKCE bypass via downgrade attack
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework https://github.com/cloudflare/workers-mcp . However, it was found that an attacker could cause the check to be skipped. Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 https://github.com/cloudflare/workers-oauth-provider/pull/27 Impact: PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.). This bug completely bypasses PKCE protection.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @cloudflare/workers-oauth-provider (npm) | before 0.0.5 | 0.0.5 | Patch available | GHSA-qgp8-v765-qxx9 |
- @cloudflare/workers-oauth-provider (npm) Vendor— Affected before 0.0.5 Fixed in 0.0.5 Patch available GHSA-qgp8-v765-qxx9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:workers-oauth-provider:0.0.5:*:*:*:*:*:*:* | 0.0.5 | Vulnerable | Cloudflare |
- cpe:2.3:a:cloudflare:workers-oauth-provider:0.0.5:*:*:*:*:*:*:* Versions 0.0.5 Vulnerable ·Cloudflare
Remediation
- Fix · GHSA-qgp8-v765-qxx9 @cloudflare/workers-oauth-provider (npm) Fixed in 0.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4144
- 2026-10-03 Alias added: GHSA-qgp8-v765-qxx9
References
More Cloudflare Workers-oauth-provider vulnerabilities
- TI-2025-03680 Missing validation of redirect_uri on authorize endpoint CVSS 4.0MEDIUM 6.0
Sources
- CVE-2025-4144 · CVE Program
- CVE-2025-4144 · NVD
- FIRST EPSS
- GHSA-qgp8-v765-qxx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences