Input validation issue in AWS Amplify Studio UI component properties
Priority HIGH 80CWE-95Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
The AWS Amplify Studio UI component property expressions in the aws-amplify/amplify-codegen-ui package lack input validation. This could potentially allow an authenticated user who has access to create or modify components to run arbitrary JavaScript code during the component rendering and build process.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00993 62nd percentileScored 2026-11-07
Fix Fixed Amplify Studio (Amazon): 2.20.3@aws-amplify/codegen-ui-react (npm): 2.20.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Amplify Studio | 0.1.0 to before 2.20.3 | 2.20.3 | Patch available | CNA |
| — | @aws-amplify/codegen-ui-react (npm) | before 2.20.3 | 2.20.3 | Patch available | GHSA-hf3j-86p7-mfw8 |
- Amplify Studio VendorAWS Affected 0.1.0 to before 2.20.3 Fixed in 2.20.3 Patch available CNA
- @aws-amplify/codegen-ui-react (npm) Vendor— Affected before 2.20.3 Fixed in 2.20.3 Patch available GHSA-hf3j-86p7-mfw8
Remediation
- Fix · CNA Amplify Studio (Amazon) Fixed in 2.20.3
- Fix · GHSA-hf3j-86p7-mfw8 @aws-amplify/codegen-ui-react (npm) Fixed in 2.20.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4318
- 2026-10-03 Alias added: GHSA-hf3j-86p7-mfw8
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
- TI-2022-13159 Unsafe YAML deserialization in opensearch-ruby CVSS 3.1HIGH 8.8
Sources
- CVE-2025-4318 · CVE Program
- CVE-2025-4318 · NVD
- FIRST EPSS
- GHSA-hf3j-86p7-mfw8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences