Post Slider and Carousel with Widget < 3.2.10 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Slider and Post Carousel with Post Vertical Scrolling Widget WordPress plugin before 3.2.10 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Slider and Post Carousel with Post Vertical Scrolling Widget | before 3.2.10 | 3.2.10 | Patch available | CNA |
- Post Slider and Post Carousel with Post Vertical Scrolling Widget VendorUnknown Affected before 3.2.10 Fixed in 3.2.10 Patch available CNA
Remediation
- Fix · CNA Post Slider and Post Carousel with Post Vertical Scrolling Widget (Unknown) Fixed in 3.2.10
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4567
- 2026-10-03 Alias added: GHSA-4rgj-78j5-635j
References
Sources
- CVE-2025-4567 · CVE Program
- CVE-2025-4567 · NVD
- FIRST EPSS
- GHSA-4rgj-78j5-635j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences