WordPress Infinite Scroll – Ajax Load More <= 7.4.0.1 - Authenticated(Contributor+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Infinite Scroll – Ajax Load More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the data-button-label HTML attribute in all versions up to, and including, 7.4.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4775
- 2026-10-03 Alias added: GHSA-8f99-8499-8v6g
References
More dcooney vulnerabilities
- TI-2015-08068 Ajax Load More < 2.8.1.2 - Subscriber+ File Upload & Deletion CVSS 3.1HIGH 8.8
- TI-2022-04081 WordPress Infinite Scroll - Ajax Load More < 5.6.0.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-02721 WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Authenticated (Admin+) Arbitrary File Read CVSS 3.1MEDIUM 4.9
- TI-2022-02247 WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Cross-Site Request Forgery to PHAR Deserialization CVSS 3.1HIGH 8.8
- TI-2024-00802 Instant Images <= 6.1.0 - Authenticated (Author+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2023-12183 WordPress Instant Images Plugin <= 5.1.0.2 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2025-4775 · CVE Program
- CVE-2025-4775 · NVD
- FIRST EPSS
- GHSA-8f99-8499-8v6g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences