Unrestricted file upload in ValvePress WordPress Automatic Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The WordPress Automatic Plugin plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'core.php' file in all versions up to, and including, 3.115.0. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ValvePress | WordPress Automatic Plugin | up to 3.115.0 | — | No fix listed | CNA |
- WordPress Automatic Plugin VendorValvePress Affected up to 3.115.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5395
- 2026-10-03 Alias added: GHSA-v36v-wjrw-5jxg
References
More ValvePress vulnerabilities
- TI-2024-18559 WordPress Automatic plugin <= 3.92.0 - Unauthenticated Arbitrary SQL Execution vulnerability CVSS 3.1CRITICAL 9.9
- TI-2021-03231 WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2021-03237 Pinterest Automatic <= 4.14.3 - Unuathenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2025-26252 WordPress Pinterest Automatic Pin plugin < 4.19.0 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-26235 WordPress Rankie plugin < 1.8.2 - Broken Access Control Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-26228 WordPress Rankie plugin < 1.8.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
Sources
- CVE-2025-5395 · CVE Program
- CVE-2025-5395 · NVD
- FIRST EPSS
- GHSA-v36v-wjrw-5jxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences