Read the docs
TI-2025-26252 Aliases CVE-2025-39510GHSA-9r4p-w669-7h3m

WordPress Pinterest Automatic Pin plugin < 4.19.0 - SQL Injection vulnerability

Priority MEDIUM 45CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ValvePress Pinterest Automatic Pin wp-pinterest-automatic allows SQL Injection.This issue affects Pinterest Automatic Pin: from n/a through < 4.19.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00305 23rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ValvePressPinterest Automatic Pinup to 4.19.0—No fix listedCNA
  • Pinterest Automatic Pin VendorValvePress Affected up to 4.19.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-39510
  2. 2026-10-03 Alias added: GHSA-9r4p-w669-7h3m

References

  • TI-2024-18559 WordPress Automatic plugin <= 3.92.0 - Unauthenticated Arbitrary SQL Execution vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2021-03231 WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
  • TI-2021-03237 Pinterest Automatic <= 4.14.3 - Unuathenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
  • TI-2025-04847 Unrestricted file upload in ValvePress WordPress Automatic Plugin CVSS 3.1HIGH 8.8
  • TI-2025-26235 WordPress Rankie plugin < 1.8.2 - Broken Access Control Vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-26228 WordPress Rankie plugin < 1.8.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
See all 14 →

Sources