Authenticated Remote Code Execution in Multiple WSO2 Products via Event Processor Admin Service
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
An authenticated remote code execution (RCE) vulnerability exists in multiple WSO2 products due to improper input validation in the event processor admin service. A user with administrative access to the SOAP admin services can exploit this flaw by deploying a Siddhi execution plan containing malicious Java code, resulting in arbitrary code execution on the server. Exploitation of this vulnerability requires a valid user account with administrative privileges, limiting the attack surface to authenticated but potentially malicious users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 3.0.0 to before 3.0.0.174; 3.1.0 to before 3.1.0.330; 3.2.0 to before 3.2.0.426; 3.2.1 to before 3.2.1.46; 4.0.0 to before 4.0.0.344; 4.1.0 to before 4.1.0.208; 4.2.0 to before 4.2.0.147; 4.3.0 to before 4.3.0.59; 4.4.0 to before 4.4.0.22; 4.5.0 to before 4.5.0.6 | 3.0.0.174, 3.1.0.330, 3.2.0.426, 3.2.1.46, 4.0.0.344, 4.1.0.208, 4.2.0.147, 4.3.0.59, 4.4.0.22, 4.5.0.6 | Patch available | CNA |
| WSO2 | WSO2 Open Banking AM | 2.0.0 to before 2.0.0.379 | 2.0.0.379 | Patch available | CNA |
| WSO2 | WSO2 Traffic Manager | 4.5.0 to before 4.5.0.6 | 4.5.0.6 | Patch available | CNA |
| WSO2 | WSO2 API Control Plane | 4.5.0 to before 4.5.0.6 | 4.5.0.6 | Patch available | CNA |
| WSO2 | Siddhi Extension Evaluate Scripts | 3.2.6 to before 3.2.6.8; 3.2.7 to before 3.2.7.6; 3.2.8 to before 3.2.8.3; 3.2.10 to before 3.2.10.1; 3.2.13 to before 3.2.13.2; 3.2.14 to before 3.2.14.1 | 3.2.6.8, 3.2.7.6, 3.2.8.3, 3.2.10.1, 3.2.13.2, 3.2.14.1, 3.2.15 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 3.0.0 to before 3.0.0.174; 3.1.0 to before 3.1.0.330; 3.2.0 to before 3.2.0.426; 3.2.1 to before 3.2.1.46; 4.0.0 to before 4.0.0.344; 4.1.0 to before 4.1.0.208; 4.2.0 to before 4.2.0.147; 4.3.0 to before 4.3.0.59; 4.4.0 to before 4.4.0.22; 4.5.0 to before 4.5.0.6 Fixed in 3.0.0.174, 3.1.0.330, 3.2.0.426, 3.2.1.46, 4.0.0.344, 4.1.0.208, 4.2.0.147, 4.3.0.59, 4.4.0.22, 4.5.0.6 Patch available CNA
- WSO2 Open Banking AM VendorWSO2 Affected 2.0.0 to before 2.0.0.379 Fixed in 2.0.0.379 Patch available CNA
- WSO2 Traffic Manager VendorWSO2 Affected 4.5.0 to before 4.5.0.6 Fixed in 4.5.0.6 Patch available CNA
- WSO2 API Control Plane VendorWSO2 Affected 4.5.0 to before 4.5.0.6 Fixed in 4.5.0.6 Patch available CNA
- Siddhi Extension Evaluate Scripts VendorWSO2 Affected 3.2.6 to before 3.2.6.8; 3.2.7 to before 3.2.7.6; 3.2.8 to before 3.2.8.3; 3.2.10 to before 3.2.10.1; 3.2.13 to before 3.2.13.2; 3.2.14 to before 3.2.14.1 Fixed in 3.2.6.8, 3.2.7.6, 3.2.8.3, 3.2.10.1, 3.2.13.2, 3.2.14.1, 3.2.15 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_control_plane:4.5.0:-:*:*:*:*:*:* | 4.5.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* | 4.4.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_control_plane:4.5.0:-:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.0.0.174, 3.1.0.330, 3.2.0.426, 3.2.1.46, 4.0.0.344, 4.1.0.208, 4.2.0.147, 4.3.0.59, 4.4.0.22, 4.5.0.6
- Fix · CNA WSO2 Open Banking AM (WSO2) Fixed in 2.0.0.379
- Fix · CNA WSO2 Traffic Manager (WSO2) Fixed in 4.5.0.6
- Fix · CNA WSO2 API Control Plane (WSO2) Fixed in 4.5.0.6
- Fix · CNA Siddhi Extension Evaluate Scripts (WSO2) Fixed in 3.2.6.8, 3.2.7.6, 3.2.8.3, 3.2.10.1, 3.2.13.2, 3.2.14.1, 3.2.15
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5717
- 2026-10-03 Alias added: GHSA-2h9p-q5rr-fvrp
References
More WSO2 Api Control Plane vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
- TI-2025-09712 Potential Broken Access Control in Multiple WSO2 Products via System REST APIs CVSS 3.1CRITICAL 9.8
- TI-2025-08391 Improper Privilege Management in Multiple WSO2 API Manager via keymanager-operations DCR Endpoint CVSS 3.1CRITICAL 9.8
- TI-2026-01411 Privilege Escalation via System REST APIs in Multiple WSO2 Products Permits Admin Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08536 Improper Certificate-Based Authentication Enforcement in Multiple WSO2 Products CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-5717 · CVE Program
- CVE-2025-5717 · NVD
- FIRST EPSS
- GHSA-2h9p-q5rr-fvrp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences