Read the docs
TI-2025-05259 Aliases CVE-2025-5831GHSA-qcv8-39fr-gcc3

Droip < 2.5.2 - Authenticated (Subscriber+) Arbitrary File Upload

Priority MEDIUM 41CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.

Summary

The Droip plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the make_google_font_offline() function in all versions up to, and excluding, 2.5.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00745 55th percentileScored 2026-11-07
Fix Fixed Droip (Droip): 2.5.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DroipDroipbefore 2.5.22.5.2Patch availableCNA
  • Droip VendorDroip Affected before 2.5.2 Fixed in 2.5.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themeum:droip:*:*:*:*:*:wordpress:*:*up to 2.2.0Vulnerablethemeum
  • cpe:2.3:a:themeum:droip:*:*:*:*:*:wordpress:*:* Versions up to 2.2.0 Vulnerable ·themeum

Remediation

  • Fix · CNA Droip (Droip) Fixed in 2.5.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-5831
  2. 2026-10-03 Alias added: GHSA-qcv8-39fr-gcc3
  3. 2026-10-16 EPSS moved to the 50th–90th percentile

References

  • TI-2024-29544 WordPress Droip plugin <= 1.1.1 - Unauthenticated Arbitrary File Download/Deletion vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-05263 Droip <= 2.2.6 - Missing Authorization to Authenticated (Subscriber+) Many Actions CVSS 3.1HIGH 8.8
  • TI-2024-29543 WordPress Droip plugin <= 1.1.1 - Subscriber+ Settings Change/Data Exposure Vulnerability CVSS 3.1MEDIUM 6.3

Sources