Aap-gateway: csrf origin checking is disabled
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-352.
Summary
A flaw was found in the Ansible aap-gateway. Cross-site request forgery (CSRF) origin checking is not done on requests from the gateway to external components, such as the controller, hub, and eda.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | automation-gateway-server | before 2.5.20250730 | 2.5.20250730 | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 8 | — | 2.5.20250730-2.el8ap | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 9 | — | 2.5.20250730-2.el9ap | Patch available | CNA |
- automation-gateway-server Vendor— Affected before 2.5.20250730 Fixed in 2.5.20250730 Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 VendorRed Hat Affected — Fixed in 2.5.20250730-2.el8ap Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 VendorRed Hat Affected — Fixed in 2.5.20250730-2.el9ap Patch available CNA
CPE names CNA · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:/a:redhat:ansible_automation_platform:2.5::el8 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 | 2.5 | — | Red Hat |
- cpe:/a:redhat:ansible_automation_platform:2.5::el8 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 Versions 2.5 — ·Red Hat
Remediation
- Fix · CNA automation-gateway-server Fixed in 2.5.20250730
Red Hat 1 advisory
- RHSA-2025:12772 Released 2025-08-04 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-gateway-server-2.5.20250730-2.el8ap, python3.11-django-ansible-base-2.5.20250730-1.el8ap
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-gateway-server-2.5.20250730-2.el9ap, python3.11-django-ansible-base-2.5.20250730-1.el9ap
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Red Hat Ansible Automation Platform 2.5 for RHEL 8, Red Hat Ansible Automation Platform 2.5 for RHEL 9 — RHSA-2025:12772
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-07063 Python3.11-django-ansible-base: sensitive authenticator secrets returned in clear text via api in aapPriority LOW 20
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2025:12772 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 9 | Fixed | RHSA-2025:12772 |
Not affected: 2 products
- Red Hat Ansible Automation Platform 2.5 for RHEL 8
- Red Hat Ansible Automation Platform 2.5 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5988
- 2026-10-03 Alias added: GHSA-w8g9-rc94-7pq8
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-5988 · CVE Program
- CVE-2025-5988 · NVD
- FIRST EPSS
- GHSA-w8g9-rc94-7pq8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-5988 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences