Python3.11-django-ansible-base: sensitive authenticator secrets returned in clear text via api in aap
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-312.
Summary
A flaw was found in Ansible Automation Platform (AAP) where the Gateway API returns the client secret for certain GitHub Enterprise authenticators in clear text. This vulnerability affects administrators or auditors accessing authenticator configurations. While access is limited to privileged users, the clear text exposure of sensitive credentials increases the risk of accidental leaks or misuse.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ansible | django-ansible-base | before 2025.7.22 | 2025.7.22 | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 8 | — | 2.5.20250730-1.el8ap | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 9 | — | 2.5.20250730-1.el9ap | Patch available | CNA |
- django-ansible-base VendorAnsible Affected before 2025.7.22 Fixed in 2025.7.22 Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 VendorRed Hat Affected — Fixed in 2.5.20250730-1.el8ap Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 VendorRed Hat Affected — Fixed in 2.5.20250730-1.el9ap Patch available CNA
CPE names CNA · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform:2.5::el9 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform:2.5::el8 | 2.5 | — | Red Hat |
| cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 | 2.5 | — | Red Hat |
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform:2.5::el9 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform:2.5::el8 Versions 2.5 — ·Red Hat
- cpe:/a:redhat:ansible_automation_platform_developer:2.5::el8 Versions 2.5 — ·Red Hat
Remediation
- Fix · CNA django-ansible-base (Ansible) Fixed in 2025.7.22
Red Hat 1 advisory
- RHSA-2025:12772 Released 2025-08-04 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-gateway-server-2.5.20250730-2.el8ap, python3.11-django-ansible-base-2.5.20250730-1.el8ap
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-gateway-server-2.5.20250730-2.el9ap, python3.11-django-ansible-base-2.5.20250730-1.el9ap
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Red Hat Ansible Automation Platform 2.5 for RHEL 8, Red Hat Ansible Automation Platform 2.5 for RHEL 9 — RHSA-2025:12772
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-05410 Aap-gateway: csrf origin checking is disabledPriority LOW 24
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2025:12772 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 9 | Fixed | RHSA-2025:12772 |
Not affected: 2 products
- Red Hat Ansible Automation Platform 2.5 for RHEL 8
- Red Hat Ansible Automation Platform 2.5 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7738
- 2026-10-03 Alias added: GHSA-qgmq-rhmw-xw3r
References
More Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2015-01342 Ansible Tower (aka Ansible UI) before 2.0.5 allows remote organization administrators to… CVSS 2.0MEDIUM 6.5
- TI-2015-01343 Ansible Tower (aka Ansible UI) before 2.0.5 allows remote attackers to bypass… CVSS 2.0MEDIUM 5.0
- TI-2015-01245 Multiple cross-site scripting (XSS) vulnerabilities in Ansible Tower (aka Ansible UI)… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2025-7738 · CVE Program
- CVE-2025-7738 · NVD
- FIRST EPSS
- GHSA-qgmq-rhmw-xw3r · GitHub Advisory Database · CC BY 4.0
- CVE-2025-7738 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences