Memory corruption in Citrix ADC
Priority CRITICAL 99Exploited in the wildCWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
Memory overflow vulnerability leading to unintended control flow and Denial of Service in NetScaler ADC and NetScaler Gateway when configured as Gateway (VPN virtual server, ICA Proxy, CVPN, RDP Proxy) OR AAA virtual server
Why it matters now
Exploitation Active In CISA KEV since 2025-06-30CISA due date 2025-07-21
EPSS 0.10433 95th percentileScored 2026-11-07
Fix Fixed ADC (NetScaler): 47.46, 59.19, 37.236Gateway (NetScaler): 47.46, 59.19, 37.236
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Citrix | ADC | 14.1 to before 47.46; 13.1 to before 59.19; 13.1 FIPS and NDcPP to before 37.236 | 47.46, 59.19, 37.236 | Patch available | CNA |
| Citrix | Gateway | 14.1 to before 47.46; 13.1 to before 59.19; 13.1 FIPS and NDcPP to before 37.236 | 47.46, 59.19, 37.236 | Patch available | CNA |
- ADC VendorCitrix Affected 14.1 to before 47.46; 13.1 to before 59.19; 13.1 FIPS and NDcPP to before 37.236 Fixed in 47.46, 59.19, 37.236 Patch available CNA
- Gateway VendorCitrix Affected 14.1 to before 47.46; 13.1 to before 59.19; 13.1 FIPS and NDcPP to before 37.236 Fixed in 47.46, 59.19, 37.236 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* | 13.1 to before 13.1-37.236 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* | 13.1 to before 13.1-37.236 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* | 13.1 to before 13.1-59.19; 14.1 to before 14.1-47.46 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* | 13.1 to before 13.1-59.19; 14.1 to before 14.1-47.46 | Vulnerable | Citrix |
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* Versions 13.1 to before 13.1-37.236 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* Versions 13.1 to before 13.1-37.236 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* Versions 13.1 to before 13.1-59.19; 14.1 to before 14.1-47.46 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* Versions 13.1 to before 13.1-59.19; 14.1 to before 14.1-47.46 Vulnerable ·Citrix
Remediation
- Fix · CNA ADC (NetScaler) Fixed in 47.46, 59.19, 37.236
- Fix · CNA Gateway (NetScaler) Fixed in 47.46, 59.19, 37.236
Timeline
- 2025-06-30 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2025-6543
- 2026-10-03 Alias added: GHSA-9gqr-6728-fpv3
References
More Citrix Netscaler Application Delivery Controller vulnerabilities
- TI-2026-60195 Memory overflow vulnerability leading to Remote Code Execution or Denial of Service KEVCVSS 4.0CRITICAL 9.5
- TI-2026-60194 Improper input validation in Citrix ADC KEVCVSS 4.0CRITICAL 9.5
- TI-2023-04571 Unauthenticated sensitive information disclosure in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.4
- TI-2023-03284 Unauthenticated remote code execution in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.8
- TI-2026-15872 NetScaler ADC and NetScaler Gateway Security Bulletin for CVE-2026-19490 KEVCVSS 4.0CRITICAL 9.3
- TI-2026-02639 Insufficient input validation leading to memory overread KEVCVSS 4.0CRITICAL 9.3
Sources
- CVE-2025-6543 · CVE Program
- CVE-2025-6543 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-9gqr-6728-fpv3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences