Race condition in privilege cache invalidation cycle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
Under certain conditions, an authenticated user request may execute with stale privileges following an intentional change by an authorized administrator. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.24, MongoDB Server v7.0 version prior to 7.0.21 and MongoDB Server v8.0 version prior to 8.0.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 5.0 to before 5.0.31; 6.0 to before 6.0.24; 7.0 to before 7.0.21; 8.0 to before 8.0.5 | 5.0.31, 6.0.24, 7.0.21, 8.0.5 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 5.0 to before 5.0.31; 6.0 to before 6.0.24; 7.0 to before 7.0.21; 8.0 to before 8.0.5 Fixed in 5.0.31, 6.0.24, 7.0.21, 8.0.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* | 5.0.0 to before 5.0.31; 6.0.0 to before 6.0.24; 7.0.0 to before 7.0.21; 8.0.0 to before 8.0.5 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.0.31; 6.0.0 to before 6.0.24; 7.0.0 to before 7.0.21; 8.0.0 to before 8.0.5 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB Inc) Fixed in 5.0.31, 6.0.24, 7.0.21, 8.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6707
- 2026-10-03 Alias added: GHSA-2r62-3h6c-3fgx
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2025-6707 · CVE Program
- CVE-2025-6707 · NVD
- FIRST EPSS
- GHSA-2r62-3h6c-3fgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences