Pre-Authentication Denial of Service Vulnerability in MongoDB Server's OIDC Authentication
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 7.0 to before 7.0.17; 8.0 to before 8.0.5; 6.0 to before 6.0.21 | 7.0.17, 8.0.5, 6.0.21 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 7.0 to before 7.0.17; 8.0 to before 8.0.5; 6.0 to before 6.0.21 Fixed in 7.0.17, 8.0.5, 6.0.21 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* | 6.0.0 to before 6.0.21; 7.0.0 to before 7.0.17; 8.0.0 to before 8.0.5 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* Versions 6.0.0 to before 6.0.21; 7.0.0 to before 7.0.17; 8.0.0 to before 8.0.5 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB Inc) Fixed in 7.0.17, 8.0.5, 6.0.21
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
MongoDB Server 6.0.21, 7.0.17, 8.0.5
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-06093 Pre-authentication Denial of Service Stack Overflow Vulnerability in JSON Parsing via Excessive Recursion in MongoDBPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6709
- 2026-10-03 Alias added: GHSA-5cq2-33xv-h4mm
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2025-6709 · CVE Program
- CVE-2025-6709 · NVD
- FIRST EPSS
- GHSA-5cq2-33xv-h4mm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences