MongoDB Server may be susceptible to privilege escalation due to $mergeCursors stage
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
An unauthorized user may leverage a specially crafted aggregation pipeline to access data without proper authorization due to improper handling of the $mergeCursors stage in MongoDB Server. This may lead to access to data without further authorisation. This issue affects MongoDB Server MongoDB Server v8.0 versions prior to 8.0.7, MongoDB Server v7.0 versions prior to 7.0.19 and MongoDB Server v6.0 versions prior to 6.0.22
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 6.0 to before 6.0.22; 7.0 to before 7.0.19; 8.0 to before 8.0.7 | 6.0.22, 7.0.19, 8.0.7 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 6.0 to before 6.0.22; 7.0 to before 7.0.19; 8.0 to before 8.0.7 Fixed in 6.0.22, 7.0.19, 8.0.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* | 6.0.0 to before 6.0.22; 7.0.0 to before 7.0.19; 8.0.0 to before 8.0.7 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* Versions 6.0.0 to before 6.0.22; 7.0.0 to before 7.0.19; 8.0.0 to before 8.0.7 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB Inc) Fixed in 6.0.22, 7.0.19, 8.0.7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6713
- 2026-10-03 Alias added: GHSA-p3jv-2cpc-349v
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2025-6713 · CVE Program
- CVE-2025-6713 · NVD
- FIRST EPSS
- GHSA-p3jv-2cpc-349v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences