Gnuboard g6 Post Reply qa cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability, which was classified as problematic, has been found in Gnuboard g6 up to 6.0.10. This issue affects some unknown processing of the file /bbs/scrap_popin_update/qa/ of the component Post Reply Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7786
- 2026-10-03 Alias added: GHSA-9ch4-p9xc-vmxf
References
More gnuboard vulnerabilities
- TI-2022-01138 Use of a Broken or Risky Cryptographic Algorithm in gnuboard/gnuboard5 CVSS 3.1CRITICAL 9.1
- TI-2021-02762 Cross-site Scripting (XSS) - Reflected in gnuboard/gnuboard5 CVSS 3.1MEDIUM 6.1
- TI-2021-03151 gnuboard youngcart5 menu_list_update.php cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-7786 · CVE Program
- CVE-2025-7786 · NVD
- FIRST EPSS
- GHSA-9ch4-p9xc-vmxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences