Read the docs
TI-2025-07709 Aliases CVE-2025-8423GHSA-643q-prw4-99r6

My WP Translate <= 1.1 - Authenticated (Subscriber+) Missing Authorization to Arbitrary Option Read and Deletion

Priority LOW 24CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The My WP Translate plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the mtswpt_remove_plugin() and ajax_update_export_code() functions in all versions up to, and including, 1.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read and delete arbitrary WordPress options which can cause a denial of service.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00352 29th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MyThemeShopMy WP Translateup to 1.1—No fix listedCNA
  • My WP Translate VendorMyThemeShop Affected up to 1.1 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8423
  2. 2026-10-03 Alias added: GHSA-643q-prw4-99r6

References

  • TI-2025-01890 Path traversal in MyThemeShop WordPress Review Plugin: The Ultimate Solution for Building… CVSS 3.1HIGH 8.8
  • TI-2025-07711 My WP Translate <= 1.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
  • TI-2023-09695 WordPress URL Shortener by MyThemeShop Plugin <= 1.0.17 is vulnerable to Broken Access Control CVSS 3.1HIGH 8.8
  • TI-2017-13742 The my-wp-translate plugin before 1.0.4 for WordPress has CSRF. CVSS 3.0HIGH 8.8
  • TI-2023-13035 WordPress WP Shortcode by MyThemeShop Plugin <= 1.4.16 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-14308 WordPress URL Shortener by MyThemeShop Plugin <= 1.0.17 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
See all 17 →

Sources