Admin RCE via prepackaged plugins by way of misconfigured imports directory
Priority LOW 38CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00642 51st percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.11.0, 10.8.4, 10.5.9 +3github.com/mattermost/mattermost-server (Go): 10.8.4, 10.5.9, 9.11.18 +2+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.8.0 – 10.8.3; 10.5.0 – 10.5.8; 9.11.0 – 9.11.17; 10.10.0 – 10.10.1; 10.9.0 – 10.9.3 | 10.11.0, 10.8.4, 10.5.9, 9.11.18, 10.10.2, 10.9.4 | Patch available | CNA |
| — | github.com/mattermost/mattermost-server (Go) | 10.8.0 to before 10.8.4 | 10.8.4 | Patch available | GHSA-qx3f-6vq3-8j8m |
| — | github.com/mattermost/mattermost-server (Go) | 10.5.0 to before 10.5.9 | 10.5.9 | Patch available | GHSA-qx3f-6vq3-8j8m |
| — | github.com/mattermost/mattermost-server (Go) | 9.11.0 to before 9.11.18 | 9.11.18 | Patch available | GHSA-qx3f-6vq3-8j8m |
| — | github.com/mattermost/mattermost-server (Go) | 10.10.0 to before 10.10.2 | 10.10.2 | Patch available | GHSA-qx3f-6vq3-8j8m |
| — | github.com/mattermost/mattermost-server (Go) | 10.9.0 to before 10.9.4 | 10.9.4 | Patch available | GHSA-qx3f-6vq3-8j8m |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20250707221302-a8fa77f107ef | 8.0.0-20250707221302-a8fa77f107ef | Patch available | GHSA-qx3f-6vq3-8j8m |
- Mattermost VendorMattermost Affected 10.8.0 – 10.8.3; 10.5.0 – 10.5.8; 9.11.0 – 9.11.17; 10.10.0 – 10.10.1; 10.9.0 – 10.9.3 Fixed in 10.11.0, 10.8.4, 10.5.9, 9.11.18, 10.10.2, 10.9.4 Patch available CNA
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.8.0 to before 10.8.4 Fixed in 10.8.4 Patch available GHSA-qx3f-6vq3-8j8m
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.5.0 to before 10.5.9 Fixed in 10.5.9 Patch available GHSA-qx3f-6vq3-8j8m
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 9.11.0 to before 9.11.18 Fixed in 9.11.18 Patch available GHSA-qx3f-6vq3-8j8m
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.10.0 to before 10.10.2 Fixed in 10.10.2 Patch available GHSA-qx3f-6vq3-8j8m
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.9.0 to before 10.9.4 Fixed in 10.9.4 Patch available GHSA-qx3f-6vq3-8j8m
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20250707221302-a8fa77f107ef Fixed in 8.0.0-20250707221302-a8fa77f107ef Patch available GHSA-qx3f-6vq3-8j8m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.18; 10.5.0 to before 10.5.9; 10.8.0 to before 10.8.4; 10.9.0 to before 10.9.4; 10.10.0 to before 10.10.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.18; 10.5.0 to before 10.5.9; 10.8.0 to before 10.8.4; 10.9.0 to before 10.9.4; 10.10.0 to before 10.10.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.11.0, 10.8.4, 10.5.9, 9.11.18, 10.10.2, 10.9.4
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost-server (Go) Fixed in 10.8.4 Advisory →
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost-server (Go) Fixed in 10.5.9 Advisory →
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost-server (Go) Fixed in 9.11.18 Advisory →
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost-server (Go) Fixed in 10.10.2 Advisory →
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost-server (Go) Fixed in 10.9.4 Advisory →
- Fix · GHSA-qx3f-6vq3-8j8m github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20250707221302-a8fa77f107ef Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9079
- 2026-10-03 Alias added: GHSA-qx3f-6vq3-8j8m
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
Other 8
- https://github.com/mattermost/mattermost/commit/047a2c64071749367fe02d2162f6103a3d31a883
- https://github.com/mattermost/mattermost/commit/439464883aa16a329c23cd6274c4cca7e88e238f
- https://github.com/mattermost/mattermost/commit/4ff68eea0a3f3777032d31a1a82f4b1fb492a1ac
- https://github.com/mattermost/mattermost/commit/96665b9b98a17534fcd515982a2eb26950581e41
- https://github.com/mattermost/mattermost/commit/a8fa77f107efe83f09a779f8e67cbecf236b0032
- https://github.com/mattermost/mattermost/commit/b38e2eccda182212a8032539658723c7d87e0b7e
- https://github.com/mattermost/mattermost
- https://pkg.go.dev/vuln/GO-2025-3977
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-9079 · CVE Program
- CVE-2025-9079 · NVD
- FIRST EPSS
- GHSA-qx3f-6vq3-8j8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences