Welcart e-Commerce <= 2.11.20 - Authenticated (Editor+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Welcart e-Commerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via settings in all versions up to, and including, 2.11.20 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9367
- 2026-10-03 Alias added: GHSA-9ww4-wpg6-6q9x
References
More uscnanbu vulnerabilities
- TI-2023-05484 Welcart e-Commerce < 2.9.5 - Subscriber+ Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2022-03880 Welcart e-Commerce < 2.8.6 - Subscriber+ PHAR Deserialisation CVSS 3.1HIGH 8.8
- TI-2022-03786 Welcart e-Commerce < 2.8.5 - Unauthenticated Arbitrary File Access CVSS 3.1HIGH 7.5
- TI-2026-84126 Cross-site scripting in Welcart e-Commerce Plugin payment error page CVSS 4.0MEDIUM 5.3
- TI-2022-03879 Welcart e-Commerce < 2.8.5 - Subscriber+ Arbitrary File Access CVSS 3.1MEDIUM 6.5
- TI-2022-03618 Welcart e-Commerce < 2.8.4 - Subscriber+ Arbitrary Shipping Method Creation/Update/Deletion CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-9367 · CVE Program
- CVE-2025-9367 · NVD
- FIRST EPSS
- GHSA-9ww4-wpg6-6q9x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences