WP Scraper <= 5.8.1 - Authenticated (Administrator+) Server-Side Request Forgery
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.
Summary
The WP Scraper plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 5.8.1 via the wp_scraper_extract_content function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. On Cloud instances, this issue allows for metadata retrieving.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rico-macchi | WP Scraper | up to 5.8.1 | — | No fix listed | CNA |
- WP Scraper Vendorrico-macchi Affected up to 5.8.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9975
- 2026-10-03 Alias added: GHSA-63m9-crqw-hp28
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4c72abf9-f63d-4460-8c9b-10e3f65b71ba?source=cve
- https://plugins.trac.wordpress.org/browser/wp-scraper/tags/5.8.1/wp-scraper.php#L688
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3396219%40wp-scraper&new=3396219%40wp-scraper&sfp_email=&sfph_mail=
More rico-macchi vulnerabilities
- TI-2025-22268 WordPress WP Links Page plugin <= 4.9.6 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-23622 WordPress WP Featured Screenshot Plugin <= 1.3 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-09341 WP Links Page <= 4.9.6 - Authenticated (Subscriber+) SQL Injection CVSS 3.1MEDIUM 6.5
- TI-2024-05998 WP Links Page <= 4.9.5 - Missing Authorization to Authenticated (Subscriber+) Limited Image Update CVSS 3.1MEDIUM 4.3
- TI-2024-03417 WP Scraper <= 5.7 - Missing Authorization to Arbitrary Page/Post Creation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-9975 · CVE Program
- CVE-2025-9975 · NVD
- FIRST EPSS
- GHSA-63m9-crqw-hp28 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences