WP Links Page <= 4.9.6 - Authenticated (Subscriber+) SQL Injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The WP Links Page plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 4.9.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rico-macchi | WP Links Page | up to 4.9.6 | — | No fix listed | CNA |
- WP Links Page Vendorrico-macchi Affected up to 4.9.6 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-10175
- 2026-10-03 Alias added: GHSA-38j6-wgw2-r5hw
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cb753b29-ca8c-4044-97ff-3b7e57d5de61?source=cve
- https://plugins.svn.wordpress.org/wp-links-page/trunk/wp-links-page-free.php
- https://wordpress.org/plugins/wp-links-page/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3410752%40wp-links-page&new=3410752%40wp-links-page&sfp_email=&sfph_mail=
More rico-macchi vulnerabilities
- TI-2025-22268 WordPress WP Links Page plugin <= 4.9.6 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-23622 WordPress WP Featured Screenshot Plugin <= 1.3 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-09155 WP Scraper <= 5.8.1 - Authenticated (Administrator+) Server-Side Request Forgery CVSS 3.1MEDIUM 6.8
- TI-2024-05998 WP Links Page <= 4.9.5 - Missing Authorization to Authenticated (Subscriber+) Limited Image Update CVSS 3.1MEDIUM 4.3
- TI-2024-03417 WP Scraper <= 5.7 - Missing Authorization to Arbitrary Page/Post Creation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-10175 · CVE Program
- CVE-2025-10175 · NVD
- FIRST EPSS
- GHSA-38j6-wgw2-r5hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences