1Panel-dev MaxKB debug deserialization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
A vulnerability was determined in 1Panel-dev MaxKB up to 2.0.2/2.1.0. This issue affects some unknown processing of the file /admin/api/workspace/default/tool/debug. Executing manipulation of the argument code can lead to deserialization. The attack can be executed remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.1.1 is capable of addressing this issue. It is suggested to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | MaxKB | 2.0; 2.0.0; 2.0.1; 2.0.2; 2.1.0 | 2.1.1 | Patch available | CNA |
- MaxKB Vendor1Panel-dev Affected 2.0; 2.0.0; 2.0.1; 2.0.2; 2.1.0 Fixed in 2.1.1 Patch available CNA
Remediation
- Fix · CNA MaxKB (1Panel-dev) Fixed in 2.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-10433
- 2026-10-03 Alias added: GHSA-cgh6-cw7h-wg36
References
More 1Panel-dev vulnerabilities
- TI-2023-08712 KubePi's Hardcoded Jwtsigkeys allows malicious actor to login with a forged JWT token CVSS 3.1CRITICAL 9.8
- TI-2023-08729 KubeOperator is vulnerable to unauthorized access to system API CVSS 3.1CRITICAL 9.8
- TI-2026-54047 MaxKB: Prompt-injectable agent can lead to command execution CVSS 3.1CRITICAL 10.0
- TI-2025-43180 CordysCRM 1.4.1 is vulnerable to SQL Injection in the employee list query interface… CVSS 3.1CRITICAL 9.8
- TI-2024-27040 Arbitrary File Read in Ansible Playbooks in Jumpserver CVSS 3.1CRITICAL 10.0
- TI-2024-26801 a sqlinjection in 1Panel CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-10433 · CVE Program
- CVE-2025-10433 · NVD
- FIRST EPSS
- GHSA-cgh6-cw7h-wg36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences