WPC Smart Wishlist for WooCommerce <= 5.0.4 - Missing Authorization to Authenticated (Subscriber+) Information Exposure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The WPC Smart Wishlist for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'wishlist_quickview' AJAX action in all versions up to, and including, 5.0.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view other user's wishlist data and information.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-11742
- 2026-10-03 Alias added: GHSA-jpjg-wf9r-25rj
References
More wpclever vulnerabilities
- TI-2024-33849 WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22095 WordPress WPC Smart Linked Products plugin <= 1.3.5 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22042 Missing authorization in wpclever WPC Smart Upsell Funnel for WooCommerce CVSS 3.1HIGH 8.8
- TI-2024-09664 WPC Smart Messages for WooCommerce <= 4.2.1 - Authenticated (Subscriber+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2026-63681 Improper privilege management in wpclever WPC Shop as a Customer for WooCommerce CVSS 3.1HIGH 8.8
- TI-2025-03002 WPC Admin Columns 2.0.6 - 2.1.0 - Authenticated (Subscriber+) Privilege Escalation via User Meta Update CVSS 3.1HIGH 8.8
Sources
- CVE-2025-11742 · CVE Program
- CVE-2025-11742 · NVD
- FIRST EPSS
- GHSA-jpjg-wf9r-25rj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences