Colibri Page Builder <= 1.0.345 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Colibri Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the colibri_blog_posts shortcode in all versions up to, and including, 1.0.345 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| extendthemes | Colibri Page Builder | up to 1.0.345 | — | No fix listed | CNA |
- Colibri Page Builder Vendorextendthemes Affected up to 1.0.345 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:extendthemes:colibri_page_builder:*:*:*:*:*:*:*:* | — | — | extendthemes |
- cpe:2.3:a:extendthemes:colibri_page_builder:*:*:*:*:*:*:*:* Versions — — ·extendthemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-11747
- 2026-10-03 Alias added: GHSA-8h8x-gmrp-h6m6
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e3305b39-5f7b-493b-80b5-cb925c2710c1?source=cve
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/shortcodes/blog-posts.php#L251
- https://plugins.trac.wordpress.org/changeset/3421590/colibri-page-builder/trunk/extend-builder/shortcodes/blog-posts.php
More extendthemes vulnerabilities
- TI-2025-02014 Kubio AI Page Builder <= 2.5.1 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2022-04358 Materialis Companion < 1.3.40 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04096 Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2019-15245 Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-54440 WordPress Lead Generation Contact Widget & AI Chatbot: Chat Button, Phone Call, Telegram… CVSS 3.1HIGH 7.5
- TI-2024-22269 WordPress Teluro theme <= 1.0.31 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2025-11747 · CVE Program
- CVE-2025-11747 · NVD
- FIRST EPSS
- GHSA-8h8x-gmrp-h6m6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences