Account takeover on OAuth/OpenID-enabled servers
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Mattermost versions 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12, 11.0.x <= 11.0.3 fail to properly validate OAuth state tokens during OpenID Connect authentication which allows an authenticated attacker with team creation privileges to take over a user account via manipulation of authentication data during the OAuth completion flow. This requires email verification to be disabled (default: disabled), OAuth/OpenID Connect to be enabled, and the attacker to control two users in the SSO system with one of them never having logged into Mattermost.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.12.0 – 10.12.1; 10.11.0 – 10.11.4; 10.5.0 – 10.5.12; 11.0.0 – 11.0.3 | 11.1.0, 10.12.2, 10.11.5, 10.5.13, 11.0.4 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20251028000919-d3ed703dc833 | 8.0.0-20251028000919-d3ed703dc833 | Patch available | GHSA-3x39-62h4-f8j6 |
| — | github.com/mattermost/mattermost-server (Go) | 10.12.0 to before 10.12.2 | 10.12.2 | Patch available | GHSA-3x39-62h4-f8j6 |
| — | github.com/mattermost/mattermost-server (Go) | 10.11.0 to before 10.11.5 | 10.11.5 | Patch available | GHSA-3x39-62h4-f8j6 |
| — | github.com/mattermost/mattermost-server (Go) | 10.5.0 to before 10.5.13 | 10.5.13 | Patch available | GHSA-3x39-62h4-f8j6 |
| — | github.com/mattermost/mattermost-server (Go) | 11.0.0 to before 11.0.4 | 11.0.4 | Patch available | GHSA-3x39-62h4-f8j6 |
- Mattermost VendorMattermost Affected 10.12.0 – 10.12.1; 10.11.0 – 10.11.4; 10.5.0 – 10.5.12; 11.0.0 – 11.0.3 Fixed in 11.1.0, 10.12.2, 10.11.5, 10.5.13, 11.0.4 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20251028000919-d3ed703dc833 Fixed in 8.0.0-20251028000919-d3ed703dc833 Patch available GHSA-3x39-62h4-f8j6
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.12.0 to before 10.12.2 Fixed in 10.12.2 Patch available GHSA-3x39-62h4-f8j6
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0 to before 10.11.5 Fixed in 10.11.5 Patch available GHSA-3x39-62h4-f8j6
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.5.0 to before 10.5.13 Fixed in 10.5.13 Patch available GHSA-3x39-62h4-f8j6
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.0.0 to before 11.0.4 Fixed in 11.0.4 Patch available GHSA-3x39-62h4-f8j6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.5.0 to before 10.5.13; 10.11.0 to before 10.11.5; 10.12.0 to before 10.12.2; 11.0.0 to before 11.0.4 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.5.0 to before 10.5.13; 10.11.0 to before 10.11.5; 10.12.0 to before 10.12.2; 11.0.0 to before 11.0.4 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.1.0, 10.12.2, 10.11.5, 10.5.13, 11.0.4
- Fix · GHSA-3x39-62h4-f8j6 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20251028000919-d3ed703dc833 Advisory →
- Fix · GHSA-3x39-62h4-f8j6 github.com/mattermost/mattermost-server (Go) Fixed in 10.12.2 Advisory →
- Fix · GHSA-3x39-62h4-f8j6 github.com/mattermost/mattermost-server (Go) Fixed in 10.11.5 Advisory →
- Fix · GHSA-3x39-62h4-f8j6 github.com/mattermost/mattermost-server (Go) Fixed in 10.5.13 Advisory →
- Fix · GHSA-3x39-62h4-f8j6 github.com/mattermost/mattermost-server (Go) Fixed in 11.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12419
- 2026-10-03 Alias added: GHSA-3x39-62h4-f8j6
References
Advisory 3
Other 7
- https://github.com/mattermost/mattermost/pull/34296
- https://github.com/mattermost/mattermost/commit/15364790cc277cfaa372693d2d5442b87f70fd42
- https://github.com/mattermost/mattermost/commit/364c2203de00fe0d8424b6b46d6f0eeb02a2539a
- https://github.com/mattermost/mattermost/commit/46b5c436bb3093cc1da3fa2455f93d4c52389eee
- https://github.com/mattermost/mattermost/commit/c3f4818afe46a7084740e809708ae22641c76d8d
- https://github.com/mattermost/mattermost/commit/d3ed703dc8330684952eb8d49a375bac6ea7b0c6
- https://github.com/mattermost/mattermost
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-12419 · CVE Program
- CVE-2025-12419 · NVD
- FIRST EPSS
- GHSA-3x39-62h4-f8j6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences