Account Takeover via Code Exchange Endpoint
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.0.0 – 11.0.2; 10.12.0 – 10.12.1; 10.11.0 – 10.11.4; 10.5.0 – 10.5.12 | 11.1.0, 11.0.3, 10.12.2, 10.11.5, 10.5.13 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20251022210333-acda1fb5dd46 | 8.0.0-20251022210333-acda1fb5dd46 | Patch available | GHSA-mp6x-97xj-9x62 |
| — | github.com/mattermost/mattermost-server (Go) | 11.0.0 to before 11.0.3 | 11.0.3 | Patch available | GHSA-mp6x-97xj-9x62 |
| — | github.com/mattermost/mattermost-server (Go) | 10.12.0 to before 10.12.2 | 10.12.2 | Patch available | GHSA-mp6x-97xj-9x62 |
| — | github.com/mattermost/mattermost-server (Go) | 10.11.0 to before 10.11.5 | 10.11.5 | Patch available | GHSA-mp6x-97xj-9x62 |
| — | github.com/mattermost/mattermost-server (Go) | 10.5.0 to before 10.5.13 | 10.5.13 | Patch available | GHSA-mp6x-97xj-9x62 |
- Mattermost VendorMattermost Affected 11.0.0 – 11.0.2; 10.12.0 – 10.12.1; 10.11.0 – 10.11.4; 10.5.0 – 10.5.12 Fixed in 11.1.0, 11.0.3, 10.12.2, 10.11.5, 10.5.13 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20251022210333-acda1fb5dd46 Fixed in 8.0.0-20251022210333-acda1fb5dd46 Patch available GHSA-mp6x-97xj-9x62
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.0.0 to before 11.0.3 Fixed in 11.0.3 Patch available GHSA-mp6x-97xj-9x62
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.12.0 to before 10.12.2 Fixed in 10.12.2 Patch available GHSA-mp6x-97xj-9x62
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0 to before 10.11.5 Fixed in 10.11.5 Patch available GHSA-mp6x-97xj-9x62
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.5.0 to before 10.5.13 Fixed in 10.5.13 Patch available GHSA-mp6x-97xj-9x62
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.5.0 to before 10.5.13; 10.11.0 to before 10.11.5; 10.12.0 to before 10.12.2; 11.0.0 to before 11.0.3 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.5.0 to before 10.5.13; 10.11.0 to before 10.11.5; 10.12.0 to before 10.12.2; 11.0.0 to before 11.0.3 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.1.0, 11.0.3, 10.12.2, 10.11.5, 10.5.13
- Fix · GHSA-mp6x-97xj-9x62 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20251022210333-acda1fb5dd46 Advisory →
- Fix · GHSA-mp6x-97xj-9x62 github.com/mattermost/mattermost-server (Go) Fixed in 11.0.3 Advisory →
- Fix · GHSA-mp6x-97xj-9x62 github.com/mattermost/mattermost-server (Go) Fixed in 10.12.2 Advisory →
- Fix · GHSA-mp6x-97xj-9x62 github.com/mattermost/mattermost-server (Go) Fixed in 10.11.5 Advisory →
- Fix · GHSA-mp6x-97xj-9x62 github.com/mattermost/mattermost-server (Go) Fixed in 10.5.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12421
- 2026-10-03 Alias added: GHSA-mp6x-97xj-9x62
References
Other 5
- https://github.com/mattermost/mattermost/commit/5072bbf689a46b3b97b2373f26149f5891396e6b
- https://github.com/mattermost/mattermost/commit/acda1fb5dd46a2f46c76ae67012423c760525eaa
- https://github.com/mattermost/mattermost/commit/f361e7d75a7ab9df5a2106e1ceb919b94b55e41d
- https://github.com/mattermost/mattermost/commit/feb598ed2b7ac3cb78a253b032ad7e4628b0de00
- https://github.com/mattermost/mattermost
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-12421 · CVE Program
- CVE-2025-12421 · NVD
- FIRST EPSS
- GHSA-mp6x-97xj-9x62 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences