Read the docs
TI-2025-12373 Aliases CVE-2025-13543GHSA-c87j-2j6h-48gh

PostGallery <= 1.12.5 - Authenticated (Subscriber+) Arbitrary File Upload

Priority MEDIUM 42CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.

Summary

The PostGallery plugin for WordPress is vulnerable to arbitrary file uploads due to incorrect file type validation in the 'PostGalleryUploader' class functions in all versions up to, and including, 1.12.5. This makes it possible for authenticated attackers, with subscriber-level and above permissions, to upload arbitrary files on the affected site's server which may make remote code execution possible.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00809 57th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
rtowebsitesPostGalleryup to 1.12.5—No fix listedCNA
  • PostGallery Vendorrtowebsites Affected up to 1.12.5 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-13543
  2. 2026-10-03 Alias added: GHSA-c87j-2j6h-48gh

References

  • TI-2025-16252 WordPress DynamicTags plugin <= 1.4.0 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
  • TI-2025-26206 WordPress AdminQuickbar plugin <= 1.9.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2025-16525 WordPress Dynamic Conditions plugin <= 1.7.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2025-13368 AdminQuickbar <= 1.9.3 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 4.3

Sources