MongoDB Server may allow queries to be terminated by unauthorized users
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
A user with access to the cluster with a limited set of privilege actions may be able to terminate queries that are being executed by other users. This may cause a denial of service by preventing a fraction of queries from successfully completing. This issue affects MongoDB Server v7.0 versions prior to 7.0.26 and MongoDB Server v8.0 versions prior to 8.0.14
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Server | 8.0 to before 8.0.14; 7.0 to before 7.0.26 | 8.0.14, 7.0.26 | Patch available | CNA |
- MongoDB Server VendorMongoDB Affected 8.0 to before 8.0.14; 7.0 to before 7.0.26 Fixed in 8.0.14, 7.0.26 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* | 7.0.0 to before 7.0.26; 8.0.0 to before 8.0.14 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:8.2.0:alpha:*:*:-:*:*:* | 8.2.0 alpha | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:8.2.0:alpha0:*:*:-:*:*:* | 8.2.0 alpha0 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:8.2.0:alpha1:*:*:-:*:*:* | 8.2.0 alpha1 | Vulnerable | MongoDB |
| cpe:2.3:a:mongodb:mongodb:8.2.0:alpha2:*:*:-:*:*:* | 8.2.0 alpha2 | Vulnerable | MongoDB |
- cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* Versions 7.0.0 to before 7.0.26; 8.0.0 to before 8.0.14 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:8.2.0:alpha:*:*:-:*:*:* Versions 8.2.0 alpha Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:8.2.0:alpha0:*:*:-:*:*:* Versions 8.2.0 alpha0 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:8.2.0:alpha1:*:*:-:*:*:* Versions 8.2.0 alpha1 Vulnerable ·MongoDB
- cpe:2.3:a:mongodb:mongodb:8.2.0:alpha2:*:*:-:*:*:* Versions 8.2.0 alpha2 Vulnerable ·MongoDB
Remediation
- Fix · CNA MongoDB Server (MongoDB Inc.) Fixed in 8.0.14, 7.0.26
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13643
- 2026-10-03 Alias added: GHSA-p2cp-6qqj-8xqc
References
More Mongodb vulnerabilities
- TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
- TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
- TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
- TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
- TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
- TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
Sources
- CVE-2025-13643 · CVE Program
- CVE-2025-13643 · NVD
- FIRST EPSS
- GHSA-p2cp-6qqj-8xqc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences