SureForms <= 2.2.0 - Unauthenticated Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The SureForms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form field parameters in all versions up to, and including, 2.2.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Brainstorm Force | SureForms – Contact Form, Payment Form & Other Custom Form Builder | up to 2.2.0 | — | No fix listed | CNA |
- SureForms – Contact Form, Payment Form & Other Custom Form Builder VendorBrainstorm Force Affected up to 2.2.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14855
- 2026-10-03 Alias added: GHSA-6p3q-9mgc-93rh
References
More Brainstorm Force vulnerabilities
- TI-2025-19878 WordPress SureTriggers <= 1.0.82 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-02708 Incorrect comparison in Brainstorm Force OttoKit: All-in-One Automation Platform CVSS 3.1HIGH 8.1
- TI-2025-05347 SureForms < 1.7.2 - Reflected XSS CVSS 3.1MEDIUM 5.8
- TI-2020-18849 Spectra < 1.15.0 - Contributor+ Stored Cross-Side Scripting CVSS 3.1MEDIUM 5.4
- TI-2025-03050 SureForms < 1.4.4 - Contributor+ Settings Update CVSS 3.1MEDIUM 4.9
- TI-2025-11950 Starter Templates <= 4.4.41 - Authenticated (Author+) Arbitrary File Upload via WXR Upload Bypass CVSS 3.1HIGH 8.8
Sources
- CVE-2025-14855 · CVE Program
- CVE-2025-14855 · NVD
- FIRST EPSS
- GHSA-6p3q-9mgc-93rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences