Net::Dropbear versions before 0.14 for Perl contains a vulnerable version of libtomcrypt
Priority MEDIUM 50CWE-1395Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Net::Dropbear versions before 0.14 for Perl contains a vulnerable version of libtomcrypt. Net::Dropbear versions before 0.14 includes versions of Dropbear 2019.78 or earlier. These include versions of libtomcrypt v1.18.1 or earlier, which is affected by CVE-2016-6129 and CVE-2018-12437.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0057 47th percentileScored 2026-11-07
Fix Fixed Net::Dropbear (ATRODO): 0.14
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Net::Dropbear (ATRODO) Fixed in 0.14
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15638
- 2026-10-03 Alias added: GHSA-fwph-xhj4-v8r5
References
Sources
- CVE-2025-15638 · CVE Program
- CVE-2025-15638 · NVD
- FIRST EPSS
- GHSA-fwph-xhj4-v8r5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences