Insufficient Input Validation on Post Props
Priority LOW 31CWE-1287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00446 39th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.3.0, 10.2.1, 9.11.6 +2github.com/mattermost/mattermost/server/v8 (Go): 10.2.1, 10.1.4, 10.0.4 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.2.0; 9.11.0 – 9.11.5; 10.0.0 – 10.0.3; 10.1.0 – 10.1.3 | 10.3.0, 10.2.1, 9.11.6, 10.0.4, 10.1.4 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.2.0 to before 10.2.1 | 10.2.1 | Patch available | GHSA-5m7j-6gc4-ff5g |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.1.0 to before 10.1.4 | 10.1.4 | Patch available | GHSA-5m7j-6gc4-ff5g |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.0.0 to before 10.0.4 | 10.0.4 | Patch available | GHSA-5m7j-6gc4-ff5g |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.11.0 to before 9.11.6 | 9.11.6 | Patch available | GHSA-5m7j-6gc4-ff5g |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20241127161322-25ff7a3779a5 | 8.0.0-20241127161322-25ff7a3779a5 | Patch available | GHSA-5m7j-6gc4-ff5g |
- Mattermost VendorMattermost Affected 10.2.0; 9.11.0 – 9.11.5; 10.0.0 – 10.0.3; 10.1.0 – 10.1.3 Fixed in 10.3.0, 10.2.1, 9.11.6, 10.0.4, 10.1.4 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.2.0 to before 10.2.1 Fixed in 10.2.1 Patch available GHSA-5m7j-6gc4-ff5g
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.1.0 to before 10.1.4 Fixed in 10.1.4 Patch available GHSA-5m7j-6gc4-ff5g
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.0.0 to before 10.0.4 Fixed in 10.0.4 Patch available GHSA-5m7j-6gc4-ff5g
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.11.0 to before 9.11.6 Fixed in 9.11.6 Patch available GHSA-5m7j-6gc4-ff5g
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20241127161322-25ff7a3779a5 Fixed in 8.0.0-20241127161322-25ff7a3779a5 Patch available GHSA-5m7j-6gc4-ff5g
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.6; 10.0.0 to before 10.0.4; 10.1.0 to before 10.1.4 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:10.2.0:-:*:*:*:*:*:* | 10.2.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.6; 10.0.0 to before 10.0.4; 10.1.0 to before 10.1.4 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:10.2.0:-:*:*:*:*:*:* Versions 10.2.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.3.0, 10.2.1, 9.11.6, 10.0.4, 10.1.4
- Fix · GHSA-5m7j-6gc4-ff5g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.2.1 Advisory →
- Fix · GHSA-5m7j-6gc4-ff5g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.1.4 Advisory →
- Fix · GHSA-5m7j-6gc4-ff5g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.0.4 Advisory →
- Fix · GHSA-5m7j-6gc4-ff5g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.6 Advisory →
- Fix · GHSA-5m7j-6gc4-ff5g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20241127161322-25ff7a3779a5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-20086
- 2026-10-03 Alias added: GHSA-5m7j-6gc4-ff5g
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-20086 · CVE Program
- CVE-2025-20086 · NVD
- FIRST EPSS
- GHSA-5m7j-6gc4-ff5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences