Memory leak in NodeJS Node
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
A memory leak could occur when a remote peer abruptly closes the socket without sending a GOAWAY notification. Additionally, if an invalid header was detected by nghttp2, causing the connection to be terminated by the peer, the same leak was triggered. This flaw could lead to increased memory consumption and potential denial of service under certain conditions. This vulnerability affects HTTP/2 Server users on Node.js v18.x, v20.x, v22.x and v23.x.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.20.6; 19.0 and later; 20.0 to before 20.18.2; 21.0 and later; 22.0 to before 22.13.1; 23.0 to before 23.6.1 | 18.20.6, 20.18.2, 22.13.1, 23.6.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.20.6; 19.0 and later; 20.0 to before 20.18.2; 21.0 and later; 22.0 to before 22.13.1; 23.0 to before 23.6.1 Fixed in 18.20.6, 20.18.2, 22.13.1, 23.6.1 Patch available CNA
Remediation
- Fix · CNA Node (NodeJS) Fixed in 18.20.6, 20.18.2, 22.13.1, 23.6.1
Red Hat 6 advisories
- RHSA-2025:1613 Released 2025-02-17 · Red Hat rating Importantnodejs:22 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:22.13.1-1.module+el9.5.0+22763+17233acb.aarch64::nodejs:22, nodejs-1:22.13.1-1.module+el9.5.0+22763+17233acb.ppc64le::nodejs:22, nodejs-1:22.13.1-1.module+el9.5.0+22763+17233acb.s390x::nodejs:22 +28
- RHSA-2025:1611 Released 2025-02-17 · Red Hat rating Importantnodejs:22 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:22.13.1-1.module+el8.10.0+22759+46b58560.aarch64::nodejs:22, nodejs-1:22.13.1-1.module+el8.10.0+22759+46b58560.ppc64le::nodejs:22, nodejs-1:22.13.1-1.module+el8.10.0+22759+46b58560.s390x::nodejs:22 +28
- RHSA-2025:1582 Released 2025-02-17 · Red Hat rating Moderatenodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.20.6-1.module+el8.10.0+22776+24cd6c55.aarch64::nodejs:18, nodejs-1:18.20.6-1.module+el8.10.0+22776+24cd6c55.ppc64le::nodejs:18, nodejs-1:18.20.6-1.module+el8.10.0+22776+24cd6c55.s390x::nodejs:18 +20
Show 3 more Red Hat advisories
- RHSA-2025:1446 Released 2025-02-13 · Red Hat rating Moderatenodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.20.6-1.module+el9.5.0+22773+9a359385.aarch64::nodejs:18, nodejs-1:18.20.6-1.module+el9.5.0+22773+9a359385.ppc64le::nodejs:18, nodejs-1:18.20.6-1.module+el9.5.0+22773+9a359385.s390x::nodejs:18 +20
- RHSA-2025:1443 Released 2025-02-13 · Red Hat rating Importantnodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:20.18.2-1.module+el9.5.0+22758+4ad2c198.aarch64::nodejs:20, nodejs-1:20.18.2-1.module+el9.5.0+22758+4ad2c198.ppc64le::nodejs:20, nodejs-1:20.18.2-1.module+el9.5.0+22758+4ad2c198.s390x::nodejs:20 +20
- RHSA-2025:1351 Released 2025-02-12 · Red Hat rating Importantnodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.18.2-1.module+el8.10.0+22767+a3309b10.aarch64::nodejs:20, nodejs-1:20.18.2-1.module+el8.10.0+22767+a3309b10.ppc64le::nodejs:20, nodejs-1:20.18.2-1.module+el8.10.0+22767+a3309b10.s390x::nodejs:20 +20
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:1351, RHSA-2025:1582, RHSA-2025:1611 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:1443, RHSA-2025:1446, RHSA-2025:1613 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23085
- 2026-10-03 Alias added: GHSA-qv9x-c8c9-rpr8
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2025-23085 · CVE Program
- CVE-2025-23085 · NVD
- FIRST EPSS
- GHSA-qv9x-c8c9-rpr8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-23085 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences