Unauthenticated stack overflow in /v3-public/authproviders API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.8.0 to before 2.8.13; 2.9.0 to before 2.9.7; 2.10.0 to before 2.10.3 | 2.8.13, 2.9.7, 2.10.3 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.8.13 | 2.8.13 | Patch available | GHSA-xr9q-h9c7-xw8q |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.7 | 2.9.7 | Patch available | GHSA-xr9q-h9c7-xw8q |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.3 | 2.10.3 | Patch available | GHSA-xr9q-h9c7-xw8q |
- rancher VendorSUSE Affected 2.8.0 to before 2.8.13; 2.9.0 to before 2.9.7; 2.10.0 to before 2.10.3 Fixed in 2.8.13, 2.9.7, 2.10.3 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.8.13 Fixed in 2.8.13 Patch available GHSA-xr9q-h9c7-xw8q
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.7 Fixed in 2.9.7 Patch available GHSA-xr9q-h9c7-xw8q
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.3 Fixed in 2.10.3 Patch available GHSA-xr9q-h9c7-xw8q
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.8.13, 2.9.7, 2.10.3
- Fix · GHSA-xr9q-h9c7-xw8q github.com/rancher/rancher (Go) Fixed in 2.8.13 Advisory →
- Fix · GHSA-xr9q-h9c7-xw8q github.com/rancher/rancher (Go) Fixed in 2.9.7 Advisory →
- Fix · GHSA-xr9q-h9c7-xw8q github.com/rancher/rancher (Go) Fixed in 2.10.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
SUSE rancher 2.10.3, 2.8.13, 2.9.7
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2025-17158 Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First LoginPriority LOW 39
- TI-2025-17156 Rancher's SAML-based login via CLI can be denied by unauthenticated usersPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23388
- 2026-10-03 Alias added: GHSA-xr9q-h9c7-xw8q
References
Other 14
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23388
- https://github.com/rancher/rancher/security/advisories/GHSA-xr9q-h9c7-xw8q
- https://github.com/rancher/rancher/pull/48608
- https://github.com/rancher/rancher/pull/48954
- https://github.com/rancher/rancher/pull/48957
- https://github.com/rancher/rancher/pull/48958
- https://github.com/rancher/rancher/commit/5c7aded42509ae526383bb296138e8ea0dff9d13
- https://github.com/rancher/rancher/commit/92d55b799ac172734106569b61ca87bbd5affcb2
- https://github.com/rancher/rancher/commit/a263bf3466717ee4bab802d499a5a167d274813d
- https://github.com/rancher/rancher/commit/de3ffa88cc75ae3da122bd36a4489663b5157ee3
- https://github.com/rancher/rancher
- https://github.com/rancher/rancher/releases/tag/v2.10.3
- https://github.com/rancher/rancher/releases/tag/v2.8.13
- https://github.com/rancher/rancher/releases/tag/v2.9.7
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-23388 · CVE Program
- CVE-2025-23388 · NVD
- FIRST EPSS
- GHSA-xr9q-h9c7-xw8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences