Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
A Improper Access Control vulnerability in SUSE rancher allows a local user to impersonate other identities through SAML Authentication on first login. This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.8.0 to before 2.8.13; 2.9.0 to before 2.9.7; 2.10.0 to before 2.10.3 | 2.8.13, 2.9.7, 2.10.3 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.8.13 | 2.8.13 | Patch available | GHSA-mq23-vvg7-xfm4 |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.7 | 2.9.7 | Patch available | GHSA-mq23-vvg7-xfm4 |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.3 | 2.10.3 | Patch available | GHSA-mq23-vvg7-xfm4 |
- rancher VendorSUSE Affected 2.8.0 to before 2.8.13; 2.9.0 to before 2.9.7; 2.10.0 to before 2.10.3 Fixed in 2.8.13, 2.9.7, 2.10.3 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.8.13 Fixed in 2.8.13 Patch available GHSA-mq23-vvg7-xfm4
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.7 Fixed in 2.9.7 Patch available GHSA-mq23-vvg7-xfm4
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.3 Fixed in 2.10.3 Patch available GHSA-mq23-vvg7-xfm4
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.8.13, 2.9.7, 2.10.3
- Fix · GHSA-mq23-vvg7-xfm4 github.com/rancher/rancher (Go) Fixed in 2.8.13 Advisory →
- Fix · GHSA-mq23-vvg7-xfm4 github.com/rancher/rancher (Go) Fixed in 2.9.7 Advisory →
- Fix · GHSA-mq23-vvg7-xfm4 github.com/rancher/rancher (Go) Fixed in 2.10.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
SUSE rancher 2.10.3, 2.8.13, 2.9.7
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2025-17157 Unauthenticated stack overflow in /v3-public/authproviders APIPriority MEDIUM 43
- TI-2025-17156 Rancher's SAML-based login via CLI can be denied by unauthenticated usersPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23389
- 2026-10-03 Alias added: GHSA-mq23-vvg7-xfm4
References
Other 13
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-23389
- https://github.com/rancher/rancher/security/advisories/GHSA-mq23-vvg7-xfm4
- https://github.com/rancher/rancher/pull/48964
- https://github.com/rancher/rancher/pull/49030
- https://github.com/rancher/rancher/pull/49031
- https://github.com/rancher/rancher/commit/4b885322eaf9995a1054bb46e019841653dc0d10
- https://github.com/rancher/rancher/commit/cda77b743788feb8df8aedf9fd409ed0916a8723
- https://github.com/rancher/rancher/commit/f36b896a99441985a1658e1b8c504d77e52fee4f
- https://github.com/rancher/rancher
- https://github.com/rancher/rancher/releases/tag/v2.10.3
- https://github.com/rancher/rancher/releases/tag/v2.8.13
- https://github.com/rancher/rancher/releases/tag/v2.9.7
- https://pkg.go.dev/vuln/GO-2025-3490
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-23389 · CVE Program
- CVE-2025-23389 · NVD
- FIRST EPSS
- GHSA-mq23-vvg7-xfm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences